[Dirvish] slow file transfers

Dave Howorth dhoworth at mrc-lmb.cam.ac.uk
Tue Feb 22 16:30:29 UTC 2011

I have a problem with slow file transfers. It's not really related to
dirvish, except that the file transfer which are affected are those done
when making backups. But I'm hoping that people here might be able to
point me in the right direction.

I have a server that makes backups of its primary data volume in a
backup volume. The backups take a long time and I'm trying to work out
why. I ran a dirvish --init that created a 439 GB vault and it took 11
hours. That's just 11.34 MB/s so I ran some more tests. The system was
essentially idle.

Some basic parameters for the two filesystems and two others that are
involved in my tests are:

data    2.0 TB, xfs,      part of 4 disk md RAID10
backup  1.2 TB, reiserfs, part of 3 disk 3ware 9650SE RAID5
root    9.7 GB, ext4,     sdc1* primary partition
test+   9.7 GB, ext2,     sdf3 primary partition disk otherwise unused

The disks are all 1.5 TB SATA drives; a mix of Seagate and WD

* sdc1 is the root partition whilst sdc2 is part of the mdadm RAID (less
than optimal, I know)
+ sdf3 is an otherwise unused partition just for testing

I measured the disk speeds with hdparm:

# hdparm -tT /dev/mapper/vg--backup-lv--storage  207.82 MB/s
# hdparm -tT /dev/mapper/vg--storage-lv--data    103.50 MB/s
# hdparm -tT /dev/sdc  124.36 MB/s
# hdparm -tT /dev/sdf   92.34 MB/s

I copied an 8 GB file from one place to another with cp and timed the

data -> backup   11.84 MB/s
data -> sdf3     78.54 MB/s
sdf3 -> data     77.06 MB/s
backup -> data  143.30 MB/s
sdf3 -> backup   12.05 MB/s
backup -> sdf3   82.50 MB/s

So everything is understandable except writing to backup. Does anybody
have any thoughts on whether this is to be expected, or a problem with
the filesystem or hardware or ... ?

Thanks, Dave

More information about the Dirvish mailing list