[Dirvish] Re: dirvish-expire trouble with read only vault directories ?

Tony waterwingz at sbcglobal.net
Sat May 13 01:13:12 UTC 2006

On Fri, 2006-05-12 at 11:56 +0100, Dave Howorth wrote:


> But you don't say who the owner is? Which can depend on your 
> rsync/dirvish settings.

> You don't say how dirvish is set up to run rsync. Is rsync running as 
> the normal user or as some other user via a daemon?

> You certainly need to run it as a user who has permission to alter
> files.

> I don't think you need write permission to delete files? You need 
> execute permission on the directory above? But I think the issue is 
> essentially a question of ownership, not permissions.


I run dirvish and rsync all as the same user ("joe" of group "users").  

When I look at the vaults, all files and directories are owned by "joe"
of group "users".

If I log in as "joe" and go to those directories, I can't manually
delete files ( rm image001.jpg ) if the w bit for the woner of the
directory is not set.  This was the simple experiment I actually tried
in order to figure this out.

I suspect the original idea was to create vaults that could not
accidentally be changed ?   If I can't find the spot in the code to fix
this, I suppose I could use a script from cron to change all directories
prior to launching dirvish-expire and then change them back after it
runs with a second script.  


More information about the Dirvish mailing list